Home Forums Software Development Kit (SDK) unable to compile litedemo on nanoPC-T4

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #15752

    Hi,

    I am trying to compile the litedemo on the sdk folder for platform aarch64. The installation of the sdk was successful. This is done on NanoPC-T4 (https://www.friendlyarm.com/index.php?route=product/product&product_id=225) and running OS is Ubuntu 16.04.6 LTS and the CPU arch is aarch64. When trying to compile the litedemo , I am getting the following error.

    pi@FriendlyELEC:~/GTISDK-Linux_aarch64_v4.5.0.3/Apps/liteDemo$ make
    g++ -DLINUX -g -o liteDemo -std=c++11 *.cpp -I ../../Include/ \
    -L ../../Lib/Linux/aarch64/ -lGTILibrary-static -l:libftd3xx.so -Wl,-rpath=”/home/pi/GTISDK-Linux_aarch64_v4.5.0.3/Apps/liteDemo”/../../Lib/Linux/aarch64 \
    -l:libstdc++.so.6 -pthread -ldl -lgomp
    ../../Lib/Linux/aarch64//libGTILibrary-static.a: error adding symbols: File format not recognized
    collect2: error: ld returned 1 exit status
    GNUmakefile:26: recipe for target ‘all’ failed
    make: *** [all] Error 1

    Can anyone help me with this? Is this SDK contains libs that are not compiled for aarch64?

    Thanks,
    Naveen

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.